Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Imprimantes scanners et Appareils Photo [Réglé] Impression KO Suite aux dernières mises à jour

clicere83 Membre non connecté

Rang

Avatar

Inscrit le : 29/04/2013 à 16h56

Messages: 366

Le 17/11/2018 à 15h07
Bonjour,

Depuis les dernières mises à jour de novembre, l'impression ne fonctionne plus.
J'ai réinstallé les pilotes de mon imprimante Brother MFCJ870DW, il y a eu de nombreux paquets manquants, ci-dessous la log de l'installation des drivers :
[size=10][root@linux Brother]# ./linux-brprinter-installer-2.2.1-1
Input model name ->mfcj870dw
                                                                                                              
You are going to install following packages.
  mfcj870dwlpr-3.0.0-1.i386.rpm
  mfcj870dwcupswrapper-3.0.0-1.i386.rpm
  brscan4-0.4.6-1.x86_64.rpm
  brscan-skey-0.2.4-1.x86_64.rpm                                                                              
OK? [y/N] ->y                                                                                                  
                                                                                                              
dnf install glibc.i686
google-earth                                                                   67 kB/s | 5.2 kB     00:00     
Mageia 6 - x86_64                                                             396 kB/s |  33 MB     01:24     
skype (stable)                                                                 27 kB/s | 4.0 kB     00:00     
google-earth-pro                                                               63 kB/s | 5.2 kB     00:00     
Mageia 6 - x86_64 - Updates                                                   400 kB/s |  36 MB     01:32     
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:00:00 le sam. 17 nov. 2018 14:48:18 C
ET.
Aucune correspondance pour l’argument : glibc.i686
Erreur : Impossible de trouver une correspondance
dnf install libstdc++.i686
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:01:25 le sam. 17 nov. 2018 14:48:18 C
ET.
Aucune correspondance pour l’argument : libstdc++.i686
Erreur : Impossible de trouver une correspondance
rpm -ihv --nodeps --replacefiles --replacepkgs mfcj870dwlpr-3.0.0-1.i386.rpm
Préparation...                       ################################# [100%]                                  
Mise à jour / installation...
  1:mfcj870dwlpr-3.0.0-1             ################################# [100%]
rpm -ihv --nodeps --replacefiles --replacepkgs mfcj870dwcupswrapper-3.0.0-1.i386.rpm
Préparation...                       ########################################                                  
Mise à jour / installation...
mfcj870dwcupswrapper-3.0.0-1          ########################################
lpadmin -p MFCJ870DW -E -v dnssd://Brother%20MFC-J870DW._ipp._tcp.local/ -P /usr/share/cups/model/Brother/brot
her_mfcj870dw_printer_en.ppd
#
dnf install policycoreutils-python
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:01:36 le sam. 17 nov. 2018 14:48:18 C
ET.
Dépendances résolues.
==============================================================================================================
Paquet                            Architecture      Version                  Dépôt                     Taille
==============================================================================================================
Installation de :
policycoreutils-python            x86_64            2.5-10.mga6              mageia-x86_64             227 k
Installation des dépendances:
cgroup                            x86_64            0.41-1.1.mga6            updates-x86_64             82 k
checkpolicy                       x86_64            2.5-1.mga6               mageia-x86_64             248 k
lib64apol4                        x86_64            3.3.8-15.mga6            mageia-x86_64              83 k
lib64cgroup1                      x86_64            0.41-1.1.mga6            updates-x86_64             46 k
lib64qpol1                        x86_64            3.3.8-15.mga6            mageia-x86_64             294 k
lib64semanage1                    x86_64            2.5-6.mga6               mageia-x86_64              89 k
lib64sepol1                       x86_64            2.5-1.mga6               mageia-x86_64             226 k
lib64ustr1                        x86_64            1.0.4-12.mga6            mageia-x86_64              87 k
libselinux-python                 x86_64            2.5-6.mga6               mageia-x86_64             154 k
libselinux-utils                  x86_64            2.5-6.mga6               mageia-x86_64             218 k
libsemanage-python                x86_64            2.5-6.mga6               mageia-x86_64              65 k
policycoreutils                   x86_64            2.5-10.mga6              mageia-x86_64             594 k
python-IPy                        noarch            0.81-11.mga6             mageia-x86_64              35 k
python-audit                      x86_64            2.7.7-1.mga6             mageia-x86_64              74 k

Résumé de la transaction
==============================================================================================================
Installer  15 Paquets

Taille totale des téléchargements : 2.5 M
Taille des paquets installés : 11 M
Voulez-vous continuer ? [o/N] :o
Téléchargement des paquets :
(1/15): lib64apol4-3.3.8-15.mga6.x86_64.rpm                                   140 kB/s |  83 kB     00:00     
(2/15): checkpolicy-2.5-1.mga6.x86_64.rpm                                     148 kB/s | 248 kB     00:01     
(3/15): policycoreutils-python-2.5-10.mga6.x86_64.rpm                         119 kB/s | 227 kB     00:01     
(4/15): libsemanage-python-2.5-6.mga6.x86_64.rpm                               99 kB/s |  65 kB     00:00     
(5/15): lib64qpol1-3.3.8-15.mga6.x86_64.rpm                                   147 kB/s | 294 kB     00:02     
(6/15): python-IPy-0.81-11.mga6.noarch.rpm                                     97 kB/s |  35 kB     00:00     
(7/15): python-audit-2.7.7-1.mga6.x86_64.rpm                                  106 kB/s |  74 kB     00:00     
(8/15): lib64semanage1-2.5-6.mga6.x86_64.rpm                                  127 kB/s |  89 kB     00:00     
(9/15): libselinux-python-2.5-6.mga6.x86_64.rpm                               121 kB/s | 154 kB     00:01     
(10/15): lib64sepol1-2.5-1.mga6.x86_64.rpm                                    126 kB/s | 226 kB     00:01     
(11/15): policycoreutils-2.5-10.mga6.x86_64.rpm                               162 kB/s | 594 kB     00:03     
(12/15): libselinux-utils-2.5-6.mga6.x86_64.rpm                               181 kB/s | 218 kB     00:01     
(13/15): lib64ustr1-1.0.4-12.mga6.x86_64.rpm                                  251 kB/s |  87 kB     00:00     
(14/15): cgroup-0.41-1.1.mga6.x86_64.rpm                                       74 kB/s |  82 kB     00:01     
(15/15): lib64cgroup1-0.41-1.1.mga6.x86_64.rpm                                 64 kB/s |  46 kB     00:00     
--------------------------------------------------------------------------------------------------------------
Total                                                                         373 kB/s | 2.5 MB     00:06      
Test de la transaction en cours
La vérification de la transaction a réussi.
Lancement de la transaction de test
Transaction de test réussie.
Exécution de la transaction
 Préparation           :                                                                                 1/1  
 Installation de       : lib64sepol1-2.5-1.mga6.x86_64                                                  1/15  
 Installation de       : lib64cgroup1-0.41-1.1.mga6.x86_64                                              2/15  
 Exécution du scriptlet: cgroup-0.41-1.1.mga6.x86_64                                                    3/15  
 Installation de       : cgroup-0.41-1.1.mga6.x86_64                                                    3/15  
 Exécution du scriptlet: cgroup-0.41-1.1.mga6.x86_64                                                    3/15  
 Installation de       : lib64qpol1-3.3.8-15.mga6.x86_64                                                4/15  
 Installation de       : lib64apol4-3.3.8-15.mga6.x86_64                                                5/15  
 Installation de       : libselinux-utils-2.5-6.mga6.x86_64                                             6/15  
 Installation de       : lib64ustr1-1.0.4-12.mga6.x86_64                                                7/15  
 Installation de       : lib64semanage1-2.5-6.mga6.x86_64                                               8/15  
 Installation de       : policycoreutils-2.5-10.mga6.x86_64                                             9/15  
 Installation de       : libselinux-python-2.5-6.mga6.x86_64                                           10/15  
 Installation de       : libsemanage-python-2.5-6.mga6.x86_64                                          11/15  
 Installation de       : python-audit-2.7.7-1.mga6.x86_64                                              12/15  
 Installation de       : python-IPy-0.81-11.mga6.noarch                                                13/15  
 Installation de       : checkpolicy-2.5-1.mga6.x86_64                                                 14/15  
 Installation de       : policycoreutils-python-2.5-10.mga6.x86_64                                     15/15  
 Exécution du scriptlet: policycoreutils-python-2.5-10.mga6.x86_64                                     15/15  
 Vérification de       : policycoreutils-python-2.5-10.mga6.x86_64                                      1/15  
 Vérification de       : checkpolicy-2.5-1.mga6.x86_64                                                  2/15  
 Vérification de       : lib64apol4-3.3.8-15.mga6.x86_64                                                3/15  
 Vérification de       : lib64qpol1-3.3.8-15.mga6.x86_64                                                4/15  
 Vérification de       : libsemanage-python-2.5-6.mga6.x86_64                                           5/15  
 Vérification de       : policycoreutils-2.5-10.mga6.x86_64                                             6/15  
 Vérification de       : python-IPy-0.81-11.mga6.noarch                                                 7/15  
 Vérification de       : python-audit-2.7.7-1.mga6.x86_64                                               8/15  
 Vérification de       : lib64semanage1-2.5-6.mga6.x86_64                                               9/15  
 Vérification de       : libselinux-python-2.5-6.mga6.x86_64                                           10/15  
 Vérification de       : lib64sepol1-2.5-1.mga6.x86_64                                                 11/15  
 Vérification de       : libselinux-utils-2.5-6.mga6.x86_64                                            12/15  
 Vérification de       : cgroup-0.41-1.1.mga6.x86_64                                                   13/15  
 Vérification de       : lib64cgroup1-0.41-1.1.mga6.x86_64                                             14/15  
 Vérification de       : lib64ustr1-1.0.4-12.mga6.x86_64                                               15/15  

Installé :
 policycoreutils-python.x86_64 2.5-10.mga6                cgroup.x86_64 0.41-1.1.mga6                         
 checkpolicy.x86_64 2.5-1.mga6                            lib64apol4.x86_64 3.3.8-15.mga6                     
 lib64cgroup1.x86_64 0.41-1.1.mga6                        lib64qpol1.x86_64 3.3.8-15.mga6                     
 lib64semanage1.x86_64 2.5-6.mga6                         lib64sepol1.x86_64 2.5-1.mga6                       
 lib64ustr1.x86_64 1.0.4-12.mga6                          libselinux-python.x86_64 2.5-6.mga6                 
 libselinux-utils.x86_64 2.5-6.mga6                       libsemanage-python.x86_64 2.5-6.mga6                
 policycoreutils.x86_64 2.5-10.mga6                       python-IPy.noarch 0.81-11.mga6                      
 python-audit.x86_64 2.7.7-1.mga6                         

Terminé !
dnf install policycoreutils
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:02:15 le sam. 17 nov. 2018 14:48:18 C
ET.
Le paquet policycoreutils-2.5-10.mga6.x86_64 est déjà installé, ignorer
Dépendances résolues.
Rien à faire.
Terminé !
dnf install policycoreutils-python-utils
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:02:17 le sam. 17 nov. 2018 14:48:18 C
ET.
Dépendances résolues.
==============================================================================================================
Paquet                                 Architecture     Version                Dépôt                   Taille
==============================================================================================================
Installation de :
policycoreutils-python-utils           x86_64           2.5-10.mga6            mageia-x86_64            60 k
Installation des dépendances:
audit                                  x86_64           2.7.7-1.mga6           mageia-x86_64           235 k
libselinux-python3                     x86_64           2.5-6.mga6             mageia-x86_64           154 k
libsemanage-python3                    x86_64           2.5-6.mga6             mageia-x86_64            67 k
policycoreutils-python3                x86_64           2.5-10.mga6            mageia-x86_64           1.6 M
python3-IPy                            noarch           0.81-11.mga6           mageia-x86_64            36 k
python3-audit                          x86_64           2.7.7-1.mga6           mageia-x86_64            74 k

Résumé de la transaction
==============================================================================================================
Installer  7 Paquets

Taille totale des téléchargements : 2.3 M
Taille des paquets installés : 5.5 M
Voulez-vous continuer ? [o/N] :o^COpération avortée.

root@linux Brother]# ./linux-brprinter-installer-2.2.1-1
Input model name ->mfcj870dw
                                                                                                              
You are going to install following packages.
  mfcj870dwlpr-3.0.0-1.i386.rpm
  mfcj870dwcupswrapper-3.0.0-1.i386.rpm
  brscan4-0.4.6-1.x86_64.rpm
  brscan-skey-0.2.4-1.x86_64.rpm                                                                              
OK? [y/N] ->y                                                                                                  
                                                                                                              
dnf install glibc.i686
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:04:50 le sam. 17 nov. 2018 14:48:18 C
ET.
Aucune correspondance pour l’argument : glibc.i686
Erreur : Impossible de trouver une correspondance
dnf install libstdc++.i686
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:04:51 le sam. 17 nov. 2018 14:48:18 C
ET.
Aucune correspondance pour l’argument : libstdc++.i686
Erreur : Impossible de trouver une correspondance
rpm -ihv --nodeps --replacefiles --replacepkgs mfcj870dwlpr-3.0.0-1.i386.rpm
Préparation...                       ################################# [100%]                                  
Mise à jour / installation...
  1:mfcj870dwlpr-3.0.0-1             ################################# [100%]
rpm -ihv --nodeps --replacefiles --replacepkgs mfcj870dwcupswrapper-3.0.0-1.i386.rpm
Préparation...                       ########################################                                  
Mise à jour / installation...
mfcj870dwcupswrapper-3.0.0-1          ########################################
lpadmin -p MFCJ870DW -E -v dnssd://Brother%20MFC-J870DW._ipp._tcp.local/ -P /usr/share/cups/model/Brother/brot
her_mfcj870dw_printer_en.ppd
#
dnf install policycoreutils-python
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:05:01 le sam. 17 nov. 2018 14:48:18 C
ET.
Le paquet policycoreutils-python-2.5-10.mga6.x86_64 est déjà installé, ignorer
Dépendances résolues.
Rien à faire.
Terminé !
dnf install policycoreutils
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:05:02 le sam. 17 nov. 2018 14:48:18 C
ET.
Le paquet policycoreutils-2.5-10.mga6.x86_64 est déjà installé, ignorer
Dépendances résolues.
Rien à faire.
Terminé !
dnf install policycoreutils-python-utils
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:05:04 le sam. 17 nov. 2018 14:48:18 C
ET.
Dépendances résolues.
==============================================================================================================
Paquet                                 Architecture     Version                Dépôt                   Taille
==============================================================================================================
Installation de :
policycoreutils-python-utils           x86_64           2.5-10.mga6            mageia-x86_64            60 k
Installation des dépendances:
audit                                  x86_64           2.7.7-1.mga6           mageia-x86_64           235 k
libselinux-python3                     x86_64           2.5-6.mga6             mageia-x86_64           154 k
libsemanage-python3                    x86_64           2.5-6.mga6             mageia-x86_64            67 k
policycoreutils-python3                x86_64           2.5-10.mga6            mageia-x86_64           1.6 M
python3-IPy                            noarch           0.81-11.mga6           mageia-x86_64            36 k
python3-audit                          x86_64           2.7.7-1.mga6           mageia-x86_64            74 k

Résumé de la transaction
==============================================================================================================
Installer  7 Paquets

Taille totale des téléchargements : 2.3 M
Taille des paquets installés : 5.5 M
Voulez-vous continuer ? [o/N] :o
Téléchargement des paquets :
(1/7): policycoreutils-python-utils-2.5-10.mga6.x86_64.rpm                    130 kB/s |  60 kB     00:00     
(2/7): libsemanage-python3-2.5-6.mga6.x86_64.rpm                              107 kB/s |  67 kB     00:00     
(3/7): libselinux-python3-2.5-6.mga6.x86_64.rpm                               126 kB/s | 154 kB     00:01     
(4/7): python3-IPy-0.81-11.mga6.noarch.rpm                                    123 kB/s |  36 kB     00:00     
(5/7): python3-audit-2.7.7-1.mga6.x86_64.rpm                                  115 kB/s |  74 kB     00:00     
(6/7): audit-2.7.7-1.mga6.x86_64.rpm                                          161 kB/s | 235 kB     00:01     
(7/7): policycoreutils-python3-2.5-10.mga6.x86_64.rpm                         291 kB/s | 1.6 MB     00:05     
--------------------------------------------------------------------------------------------------------------
Total                                                                         380 kB/s | 2.3 MB     00:06      
Test de la transaction en cours
La vérification de la transaction a réussi.
Lancement de la transaction de test
Transaction de test réussie.
Exécution de la transaction
 Préparation           :                                                                                 1/1  
 Installation de       : libselinux-python3-2.5-6.mga6.x86_64                                            1/7  
 Installation de       : libsemanage-python3-2.5-6.mga6.x86_64                                           2/7  
 Installation de       : audit-2.7.7-1.mga6.x86_64                                                       3/7  
 Exécution du scriptlet: audit-2.7.7-1.mga6.x86_64                                                       3/7  
Created symlink /etc/systemd/system/multi-user.target.wants/auditd.service → /usr/lib/systemd/system/auditd.se
rvice.
 Installation de       : python3-audit-2.7.7-1.mga6.x86_64                                               4/7  
 Installation de       : python3-IPy-0.81-11.mga6.noarch                                                 5/7  
 Installation de       : policycoreutils-python3-2.5-10.mga6.x86_64                                      6/7  
 Installation de       : policycoreutils-python-utils-2.5-10.mga6.x86_64                                 7/7  
 Exécution du scriptlet: policycoreutils-python-utils-2.5-10.mga6.x86_64                                 7/7  
 Vérification de       : policycoreutils-python-utils-2.5-10.mga6.x86_64                                 1/7  
 Vérification de       : policycoreutils-python3-2.5-10.mga6.x86_64                                      2/7  
 Vérification de       : libselinux-python3-2.5-6.mga6.x86_64                                            3/7  
 Vérification de       : libsemanage-python3-2.5-6.mga6.x86_64                                           4/7  
 Vérification de       : python3-IPy-0.81-11.mga6.noarch                                                 5/7  
 Vérification de       : python3-audit-2.7.7-1.mga6.x86_64                                               6/7  
 Vérification de       : audit-2.7.7-1.mga6.x86_64                                                       7/7  

Installé :
 policycoreutils-python-utils.x86_64 2.5-10.mga6            audit.x86_64 2.7.7-1.mga6                        
 libselinux-python3.x86_64 2.5-6.mga6                       libsemanage-python3.x86_64 2.5-6.mga6            
 policycoreutils-python3.x86_64 2.5-10.mga6                 python3-IPy.noarch 0.81-11.mga6                  
 python3-audit.x86_64 2.7.7-1.mga6                          

Terminé !
semanage fcontext -a -t bin_t /opt/brother
ValueError: La stratégie SELinux n'est pas gérée ou la base n'est pas accessible.
restorecon -R /opt/brother
semanage fcontext -a -t cupsd_rw_etc_t /etc/opt/brother
ValueError: La stratégie SELinux n'est pas gérée ou la base n'est pas accessible.
restorecon -R /etc/opt/brother
semanage fcontext -a -t cupsd_rw_etc_t /opt/brother/Printers/(.*/)?inf(/.*)?
ValueError: La stratégie SELinux n'est pas gérée ou la base n'est pas accessible.
restorecon -R /opt/brother/Printers
semanage fcontext -a -t bin_t /opt/brother/Printers/(.*/)?lpd(/.*)?
ValueError: La stratégie SELinux n'est pas gérée ou la base n'est pas accessible.
restorecon -R /opt/brother/Printers
semanage fcontext -a -t bin_t /opt/brother/Printers/(.*/)?cupswrapper(/.*)?
ValueError: La stratégie SELinux n'est pas gérée ou la base n'est pas accessible.
restorecon -R /opt/brother/Printers
restorecon -RFv /usr/lib/cups/filter
restorecon -RFv /usr/lib64/cups/filter
setsebool -P cups_execmem 1
setsebool:  SELinux is disabled.
Will you specify the Device URI? [Y/n] ->y
                                                                                                              

0: beh                                                                                                         
1: ipps                                                                                                        
2: lpd                                                                                                         
3: hp                                                                                                          
4: ipp                                                                                                         
5: http                                                                                                        
6: socket                                                                                                      
7: https                                                                                                       
8: hpfax                                                                                                       
9: dnssd://Brother%20MFC-J870DW._ipp._tcp.local/                                                               
10: lpd://BRN30055C09C08F/BINARY_P1                                                                            
11 (I): Specify IP address.                                                                                    
12 (A): Auto. (dnssd://Brother%20MFC-J870DW._ipp._tcp.local/)                                                  
                                                                                                              
select the number of destination Device URI. ->11
                                                                                                              
enter IP address ->192.168.1.10
lpadmin -p MFCJ870DW -v socket://192.168.1.10 -E                                                               
Test Print? [y/N] ->N                                                                                          
                                                                                                              
You are going to install following packages.
  brscan4-0.4.6-1.x86_64.rpm
rpm -ihv --nodeps --replacefiles --replacepkgs brscan4-0.4.6-1.x86_64.rpm
Préparation...                       ################################# [100%]                                  
Mise à jour / installation...
  1:brscan4-0.4.6-1                  ################################# [100%]
This software is based in part on the work of the Independent JPEG Group.
You are going to install following packages.
  brscan-skey-0.2.4-1.x86_64.rpm
rpm -ihv --nodeps --replacefiles --replacepkgs brscan-skey-0.2.4-1.x86_64.rpm
Préparation...                       ################################# [100%]                                  
Mise à jour / installation...
  1:brscan-skey-0.2.4-1              ################################# [100%]
ln: impossible de créer le lien symbolique '/etc/opt/brother/scanner/brscan-skey/brscan_mail.config': Le fichi
er existe
ln: impossible de créer le lien symbolique '/etc/opt/brother/scanner/brscan-skey/brscan_mailmessage.txt': Le f
ichier existe
ln: impossible de créer le lien symbolique '/etc/opt/brother/scanner/brscan-skey/brscan-skey-0.2.4-0.cfg': Le
fichier existe
ln: impossible de créer le lien symbolique '/usr/bin/brscan-skey': Le fichier existe
attention : %post(brscan-skey-0.2.4-1.x86_64) scriptlet échoué, état de sortie 1
brsaneconfig4 -a name=MFC-J870DW model=MFC-J870DW ip=192.168.1.10
Hit Enter/Return key.                                                                                          
[root@linux Brother]#
[/size

Avez-vous eu des problèmes d'impression ?
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 7902

Le 19/11/2018 à 12h32
Bonjour,
Citation :
mfcj870dwlpr-3.0.0-1.i386.rpm

Tu installes une version 32 bits sur une configuration 64 bits. Je pense que c'est le nœud du problème.


Yves
   
clicere83 Membre non connecté

Rang

Avatar

Inscrit le : 29/04/2013 à 16h56

Messages: 366

Le 21/11/2018 à 17h24
Bonjour Papoteur,

J'ai utilisé les drivers Brother https://support.brother.com/g/b/downloadlist.aspx?c=fr&lang=fr&prod=mfcj870dw_us_eu_as&os=127&flang=English
Seuls les divers du scanner sont en x86-64.

Se sont des librairies X86-64 qui ont été installée à l'exécution du script Brother.

Je clos le sujet puisque l'impression fonctionne de nouveau, sans savoir le pourquoi du comment ???
Edité par clicere83 Le 21/11/2018 à 17h26
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie